Status Page
We are committed to providing you with transparent and up-to-date information about the performance and availability of our services. This page will keep you informed about any incidents, scheduled maintenance, and other important updates that may affect your experience.
We’re currently experiencing problems on LIVE7.
Incident Report for Henry Schein One
Resolved
This incident has been resolved.
Posted May 04, 2024 - 23:25 MDT
Investigating
We are currently investigating this issue.
Posted May 04, 2024 - 22:04 MDT
This incident affected: Dentrix Ascend Availability.